Major Network Infrastructure Maintenance
Resolved
Jul 21, 2026 at 9:12pm UTC
Stability tests were sucessfull, maintenance ended.
Affected services
Updated
Jul 21, 2026 at 9:12pm UTC
Maintenance ended
Affected services
Updated
Jul 21, 2026 at 7:39pm UTC
We have sucessfully finished the maintenance but will leave open the maintenance window because of stability tests that are still made.
Purplyx performance should now increase by a lot.
Affected services
Created
Jul 20, 2026 at 10:00pm UTC
Expected Impact: Temporary network interruptions & intermittent downtime
As part of our ongoing commitment to system reliability, we will be performing a comprehensive upgrade to our core network infrastructure during the scheduled window above.
To address the intermittent stability issues and critical outages experienced over the past few months, our team is completely replacing aging hardware and upgrading backend lines.
What we are doing:
- Hardware Replacement: Deploying next-generation managed switches to boost throughput and routing efficiency.
- Line Upgrades: Installing new, high-capacity physical and logical data lines to eliminate bottlenecks.
- Redundancy Optimization: Reconfiguring failover pathways to guarantee maximum uptime and high availability moving forward.
Impact on Services
- Intermittent Downtime: During the maintenance window, you will experience brief periods of total connectivity loss and intermittent service disruptions as we cut over to the new infrastructure.
- Data Safety: This is a infrastructure-only upgrade. No data, configurations, or personal hosted services will be modified or lost.
Status Updates
We will post live updates directly to this status page as the maintenance progresses:
- [Pre-Maintenance]: Reminder notification 24 hours before the window.
- [In Progress]: When the hardware swap begins.
- [Post-Maintenance]: Once all lines are live, verified, and stability tests have passed.
Note: If you experience connectivity issues after the maintenance window has officially closed, please try restarting your local connection or reach out to our support channel.
Continuous availability cannot be guaranteed during this maintenance window. All services and network connections will experience extended periods of complete downtime.
Thank you for your patience
Affected services